Benutzer-Werkzeuge

Webseiten-Werkzeuge


support:javafaq

Java-FAQ

Diese FAQ widment sich spezifisch Fragen zu Java selbst, da auch diese immer wieder an mich herangetragen werden.

Ist Java unsicher?

Nein. Es ist ein Programmiersprache und Laufzeitumgebung. Es ist daher nicht per se unsicherer als andere Programmiersprachen. Im Gegenteil. Viele Programmierfehler, die in anderen Sprachen häufig zu Problemen führen, können in Java gar nicht auftreten. Siehe auch http://de.wikipedia.org/wiki/Java-Laufzeitumgebung

Aber alle berichten doch von Lücken in Java. Was ist damit?

Das betrifft ausschließlich Java-Applets. Das sind kleine Programme, die zwar auch in der Sprache Java geschrieben sind, die - im Gegensatz zu Jameica und Hibiscus - jedoch nicht als Desktop-Anwendung laufen sondern im Internet-Browser. Sie sind direkt in Webseiten integriert (vergleichbar mit Flash-Animationen). Java-Applets verwendet heutztage jedoch fast niemand mehr. Also deaktiviere einfach das Java-Plugin statt Java komplett zu deinstallieren (siehe http://www.java.com/de/download/help/disable_browser.xml)

Siehe auch http://de.wikipedia.org/wiki/Java-Applet

PS: Sicherheitslücken gibt es regelmäßig auch in vielen anderen Programmen, die Daten aus dem Internet empfangen können. Populäre Beispiele sind Adobe Flash, Acrobat Reader, Apple Quicktime, MS Internet Explorer. Auch hier werden jeden Monat neue Lücken und entsprechende Updates veröffentlicht. Siehe http://www.heise.de/security/. Warum ausgerechnet Java neuerdings als Büchse der Pandorra gilt, erschließt sich mir nicht. Auch für MS Windows und sogar für vermeintliche Sicherheitsprogramme wie Antivirenscanner und Personal Firewalls werden regelmäßig Sicherheitslücken bekannt.

Nochmal: Lücken in Java betreffen Java-Applets. Nicht Desktop-Programme wie Jameica oder Hibiscus.

Warum soll ich immer noch Java 6 verwenden?

Du musst Java 6 nicht verwenden. Jameica und Hibiscus laufen völlig problemlos auch mit Java 7 bzw. Java 8. Ich selbst benutze diese Java-Versionen ebenfalls. Es gibt jedoch einige Banken, die noch veraltete SSL-Zertifikate nutzen, die von Java 7 nicht mehr akzeptiert werden. Also installiere gern Java 7. Wenn es Probleme gibt, wende dich an deine Bank und tritt ihr auf die Füsse, endlich aktuelle SSL-Zertifikate zu erstellen. Siehe auch FAQ.

Inzwischen haben die meisten Banken die veralteten SSL-Zertifikate abgelöst, sodass du in aller Regel problemlos Java 7 oder Java 8 verwenden kannst. Zumindest auf Debian-basierten Linux-Distributionen (wie Ubuntu) kann Java 6 mittlerweile sogar zu Problemen führen, wie im Blog beschrieben ist.

support/javafaq.txt · Zuletzt geändert: d.m.Y H:i von willuhn